Adding new payment method issue on mobile applications
Incident Report for Vetster
Resolved
We have fixed the issue in version 1.5.5 of the app. Please download the latest version from your app store if you are still experiencing issues.

If you require immediate assistance, please contact our customer support team by visiting https://vetster.com/support where we will be able to assist you further.
Posted Mar 07, 2023 - 15:11 EST
Monitoring
A fix has been submitted to the app stores and we are waiting for approvals.
Posted Mar 07, 2023 - 11:30 EST
Identified
We have identified the cause of the issue and are preparing a fix which will be sent to the Apple and Google app stores. We will update with additional information when available.
Posted Mar 06, 2023 - 15:20 EST
Update
Our team has identified a workaround while we address this issue. Users encountering this issue are advised to back out of the payment update screen and move forward again, where the payment update will be reflected. An alternative solution is to use a web browser to make any payment method updates.
Posted Mar 06, 2023 - 14:33 EST
Investigating
We have received reports of an intermittent issue while adding new payment methods with our mobile applications starting in v1.5.1 through to v1.5.4 on both Android and iOS. When adding a new payment method, our system will accept the request and update your account, however, the screen will sometimes appear to be in a loading state and not provide any success message.

If you require immediate assistance, please contact our customer support team by visiting https://vetster.com/support where we will be able to assist you further.

We apologize for any inconvenience this may have caused and will update this incident further once we have more information.
Posted Mar 06, 2023 - 14:22 EST
This incident affected: iOS & Android Application.