Third-party payments processor experiencing failures

Incident Report for Vetster

Resolved

The issue has been fully resolved, and all delayed payments have now been resent for processing. No further action is required.
Posted Jan 30, 2025 - 09:08 EST

Monitoring

Our payments processing partner has identified an issue communicating with their banking partners and have implemented a fix. Partner payments are now being reprocessed, and future payments should work normally. We are continuing to monitor.
Posted Jan 30, 2025 - 08:41 EST

Update

Our payments processor continues to investigate the issue.
Posted Jan 29, 2025 - 16:32 EST

Update

We are continuing to work with our payments processor to investigate the issue.
Posted Jan 29, 2025 - 13:12 EST

Update

We are continuing to investigate this issue.
Posted Jan 29, 2025 - 10:55 EST

Investigating

Our team became aware of an issue delaying automated payouts and started investigating with our payments processor.
Posted Jan 29, 2025 - 10:44 EST
This incident affected: Vetster Payments for Partners.